GenSearch 2.0

The Genealogist's Search Engine

To run GenSearch 2.0 you must have Java Web Start installed on your machine.
The Java Web Start installation page is located here. Once you've install Web Start, reload the menu on the left and click the link that launched this page. GenSearch 2.0 will be launched rather than this page.